re = /-\$[0-9]{1,3}/m
str = '{"amount":1242,"amountFormatted":"-$1,242","currency":"USD","type":"PRICING","__typename":"PriceItem"},{"localizedTitle":"Fees","localizedExplanation":"This fee covers: "} '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end