const regex = /-\$[0-9]{1,3}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-\\$[0-9]{1,3}', 'gm')
const str = `{"amount":1242,"amountFormatted":"-\$1,242","currency":"USD","type":"PRICING","__typename":"PriceItem"},{"localizedTitle":"Fees","localizedExplanation":"This fee covers: "} `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}