using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\()?0?\d{2}(?(1)\) |[ -])\d{4,5}[ -]?\d{4}$";
string input = @"00 00000000
000-000000000
000 00000-0000
00 0000-0000
(00) 0000-0000
(000) 000000000
(00( 0000-0000
00) 0000-0000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}