const regex = /^(\()?0?\d{2}(?(1)\) |[ -])\d{4,5}[ -]?\d{4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\()?0?\\d{2}(?(1)\\) |[ -])\\d{4,5}[ -]?\\d{4}$', 'gm')
const str = `00 00000000
000-000000000
000 00000-0000
00 0000-0000
(00) 0000-0000
(000) 000000000
(00( 0000-0000
00) 0000-0000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}