re = /^(\()?0?\d{2}(?(1)\) |[ -])\d{4,5}[ -]?\d{4}$/m
str = '00 00000000
000-000000000
000 00000-0000
00 0000-0000
(00) 0000-0000
(000) 000000000
(00( 0000-0000
00) 0000-0000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end