// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\()?0?\d{2}(?(1)\) |[ -])\d{4,5}[ -]?\d{4}$").unwrap();
let string = "00 00000000
000-000000000
000 00000-0000
00 0000-0000
(00) 0000-0000
(000) 000000000
(00( 0000-0000
00) 0000-0000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}