$re = '/^(\()?0?\d{2}(?(1)\) |[ -])\d{4,5}[ -]?\d{4}$/m';
$str = '00 00000000
000-000000000
000 00000-0000
00 0000-0000
(00) 0000-0000
(000) 000000000
(00( 0000-0000
00) 0000-0000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);