#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[front\](?<front>(?:(?!\[back\])(?!={3,}\s*)(.|\n))*)\[back\](?<back>(?:(?!\[front\])(?!={3,}\s*)(.|\n))*)(?:={3,}\s*|\z)|\[back\](?<back2>(?:(?!\[front\])(?!={3,}\s*)(.|\n))*)\[front\](?<front2>(?:(?!\[back\])(?!={3,}\s*)(.|\n))*)(?:={3,}\s*|\z)"
Local $sString = "===========" & @CRLF & _
"[front]" & @CRLF & _
"" & @CRLF & _
"sdfjkhsgdf" & @CRLF & _
"" & @CRLF & _
"sdkljfhgsdofgsd" & @CRLF & _
"" & @CRLF & _
"[back]" & @CRLF & _
"" & @CRLF & _
"sdkfjysgdfisd" & @CRLF & _
"(sdf)[sdfsdf]" & @CRLF & _
"[dsfsf]" & @CRLF & _
"" & @CRLF & _
"=============" & @CRLF & _
"[back]" & @CRLF & _
"" & @CRLF & _
"dddddddddddd" & @CRLF & _
"" & @CRLF & _
"[front]" & @CRLF & _
"" & @CRLF & _
"kikikiki"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")