import Foundation
let pattern = #"\[front\](?<front>(?:(?!\[back\])(?!={3,}\s*)(.|\n))*)\[back\](?<back>(?:(?!\[front\])(?!={3,}\s*)(.|\n))*)(?:={3,}\s*|\z)|\[back\](?<back2>(?:(?!\[front\])(?!={3,}\s*)(.|\n))*)\[front\](?<front2>(?:(?!\[back\])(?!={3,}\s*)(.|\n))*)(?:={3,}\s*|\z)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
===========
[front]
sdfjkhsgdf
sdkljfhgsdofgsd
[back]
sdkfjysgdfisd
(sdf)[sdfsdf]
[dsfsf]
=============
[back]
dddddddddddd
[front]
kikikiki
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)