const regex = /\[front\](?<front>(?:(?!\[back\])(?!={3,}\s*)(.|\n))*)\[back\](?<back>(?:(?!\[front\])(?!={3,}\s*)(.|\n))*)(?:={3,}\s*|\z)|\[back\](?<back2>(?:(?!\[front\])(?!={3,}\s*)(.|\n))*)\[front\](?<front2>(?:(?!\[back\])(?!={3,}\s*)(.|\n))*)(?:={3,}\s*|\z)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[front\\](?<front>(?:(?!\\[back\\])(?!={3,}\\s*)(.|\\n))*)\\[back\\](?<back>(?:(?!\\[front\\])(?!={3,}\\s*)(.|\\n))*)(?:={3,}\\s*|\\z)|\\[back\\](?<back2>(?:(?!\\[front\\])(?!={3,}\\s*)(.|\\n))*)\\[front\\](?<front2>(?:(?!\\[back\\])(?!={3,}\\s*)(.|\\n))*)(?:={3,}\\s*|\\z)', 'mg')
const str = `===========
[front]
sdfjkhsgdf
sdkljfhgsdofgsd
[back]
sdkfjysgdfisd
(sdf)[sdfsdf]
[dsfsf]
=============
[back]
dddddddddddd
[front]
kikikiki`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}