$re = '/\[front\](?<front>(?:(?!\[back\])(?!={3,}\s*)(.|\n))*)\[back\](?<back>(?:(?!\[front\])(?!={3,}\s*)(.|\n))*)(?:={3,}\s*|\z)|\[back\](?<back2>(?:(?!\[front\])(?!={3,}\s*)(.|\n))*)\[front\](?<front2>(?:(?!\[back\])(?!={3,}\s*)(.|\n))*)(?:={3,}\s*|\z)/m';
$str = '===========
[front]
sdfjkhsgdf
sdkljfhgsdofgsd
[back]
sdkfjysgdfisd
(sdf)[sdfsdf]
[dsfsf]
=============
[back]
dddddddddddd
[front]
kikikiki';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);