import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[front\\](?<front>(?:(?!\\[back\\])(?!={3,}\\s*)(.|\\n))*)\\[back\\](?<back>(?:(?!\\[front\\])(?!={3,}\\s*)(.|\\n))*)(?:={3,}\\s*|\\z)|\\[back\\](?<back2>(?:(?!\\[front\\])(?!={3,}\\s*)(.|\\n))*)\\[front\\](?<front2>(?:(?!\\[back\\])(?!={3,}\\s*)(.|\\n))*)(?:={3,}\\s*|\\z)";
final String string = "===========\n"
+ "[front]\n\n"
+ "sdfjkhsgdf\n\n"
+ "sdkljfhgsdofgsd\n\n"
+ "[back]\n\n"
+ "sdkfjysgdfisd\n"
+ "(sdf)[sdfsdf]\n"
+ "[dsfsf]\n\n"
+ "=============\n"
+ "[back]\n\n"
+ "dddddddddddd\n\n"
+ "[front]\n\n"
+ "kikikiki";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}