package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w{3,},\s\d{1,2}\s(\w{3,})`)
var str = `Tue, 8 Oct 2019 11:47:37 +0200 (GMT+02:00)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}