// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\w{3,},\s\d{1,2}\s(\w{3,})").unwrap();
let string = "Tue, 8 Oct 2019 11:47:37 +0200 (GMT+02:00)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}