re = /^\w{3,},\s\d{1,2}\s(\w{3,})/m
str = 'Tue, 8 Oct 2019 11:47:37 +0200 (GMT+02:00)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end