const regex = /((ws|http)s?:)?\/\/[-\w]+(\.\w[-\w]*)+(:\d+)?\/?(\S*[^\s-._~!$&'"{}()*+,;=:@])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((ws|http)s?:)?\\\/\\\/[-\\w]+(\\.\\w[-\\w]*)+(:\\d+)?\\\/?(\\S*[^\\s-._~!$&\'"{}()*+,;=:@])', 'gm')
const str = `//参数
https://www.www.w/dsadasdasd!@#12 3
//协议
http:http://baidu.com
https:http://baidu.com
http:https://baidu.com
https:https://baidu.com
http:add_param
https:add_param
//域名
http://百度.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}