$re = '/((ws|http)s?:)?\/\/[-\w]+(\.\w[-\w]*)+(:\d+)?\/?(\S*[^\s-._~!$&\'"{}()*+,;=:@])/m';
$str = '//参数
https://www.www.w/dsadasdasd!@#12 3
//协议
http:http://baidu.com
https:http://baidu.com
http:https://baidu.com
https:https://baidu.com
http:add_param
https:add_param
//域名
http://百度.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);