// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)((ws|http)s?:)?\/\/[-\w]+(\.\w[-\w]*)+(:\d+)?\/?(\S*[^\s-._~!$&'"{}()*+,;=:@])"#).unwrap();
let string = "//参数
https://www.www.w/dsadasdasd!@#12 3
//协议
http:http://baidu.com
https:http://baidu.com
http:https://baidu.com
https:https://baidu.com
http:add_param
https:add_param
//域名
http://百度.com
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}