import Foundation
let pattern = #"((ws|http)s?:)?\/\/[-\w]+(\.\w[-\w]*)+(:\d+)?\/?(\S*[^\s-._~!$&'"{}()*+,;=:@])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
//参数
https://www.www.w/dsadasdasd!@#12 3
//协议
http:http://baidu.com
https:http://baidu.com
http:https://baidu.com
https:https://baidu.com
http:add_param
https:add_param
//域名
http://百度.com
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)