# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((ws|http)s?:)?\/\/[-\w]+(\.\w[-\w]*)+(:\d+)?\/?(\S*[^\s-._~!$&'\"{}()*+,;=:@])"
test_str = ("//参数\n"
"https://www.www.w/dsadasdasd!@#12 3\n\n"
"//协议\n"
"http:http://baidu.com\n"
"https:http://baidu.com\n"
"http:https://baidu.com\n"
"https:https://baidu.com\n"
"http:add_param\n"
"https:add_param\n\n"
"//域名\n"
"http://百度.com\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.