using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"example\.com\/[a-zA-Z-]+[a-zA-Z]\/(?!.*\/)";
string input = @"example.com/some-url-text-here/
example.com/some-url-text/but-also-more-than-two-slashes/
example.com/text-here/one-slash-too-many/two-slashes-too-many/";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}