import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "example\\.com\\/[a-zA-Z-]+[a-zA-Z]\\/(?!.*\\/)";
final String string = "example.com/some-url-text-here/\n"
+ "example.com/some-url-text/but-also-more-than-two-slashes/\n"
+ "example.com/text-here/one-slash-too-many/two-slashes-too-many/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}