import re
regex = re.compile(r"example\.com\/[a-zA-Z-]+[a-zA-Z]\/(?!.*\/)")
test_str = ("example.com/some-url-text-here/\n"
"example.com/some-url-text/but-also-more-than-two-slashes/\n"
"example.com/text-here/one-slash-too-many/two-slashes-too-many/")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")