re = /example\.com\/[a-zA-Z-]+[a-zA-Z]\/(?!.*\/)/
str = 'example.com/some-url-text-here/
example.com/some-url-text/but-also-more-than-two-slashes/
example.com/text-here/one-slash-too-many/two-slashes-too-many/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end