$re = '/example\.com\/[a-zA-Z-]+[a-zA-Z]\/(?!.*\/)/';
$str = 'example.com/some-url-text-here/
example.com/some-url-text/but-also-more-than-two-slashes/
example.com/text-here/one-slash-too-many/two-slashes-too-many/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);