#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\{(((?<url>'\S+') : ExpandedURL:\{(?<exp_url>\S+)}(?:, |\}))+)"
Local $sString = "{'https://www.google.com/search?q=red+cars' : ExpandedURL:{https://www.google.com/search?q=red+cars&sca_esv=3c36029106bf5d13&source=hp&ei=QTuIaI_t...}, 'https://www.youtube.com/watch?v=dQw4w9WgXcQ' : ExpandedURL:{https://www.youtube.com/watch?v=dQw4w9WgXcQ/diuwheiyfgbeioyrg/39486y7834....}, 'https://www.reddit.com/' : ExpandedURL:{https://www.reddit.com/r/regex/...}}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")