package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\{(((?<url>'\S+') : ExpandedURL:\{(?<exp_url>\S+)}(?:, |\}))+)`)
var str = `{'https://www.google.com/search?q=red+cars' : ExpandedURL:{https://www.google.com/search?q=red+cars&sca_esv=3c36029106bf5d13&source=hp&ei=QTuIaI_t...}, 'https://www.youtube.com/watch?v=dQw4w9WgXcQ' : ExpandedURL:{https://www.youtube.com/watch?v=dQw4w9WgXcQ/diuwheiyfgbeioyrg/39486y7834....}, 'https://www.reddit.com/' : ExpandedURL:{https://www.reddit.com/r/regex/...}}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}