re = /^\{(((?<url>'\S+') : ExpandedURL:\{(?<exp_url>\S+)}(?:, |\}))+)/m
str = '{\'https://www.google.com/search?q=red+cars\' : ExpandedURL:{https://www.google.com/search?q=red+cars&sca_esv=3c36029106bf5d13&source=hp&ei=QTuIaI_t...}, \'https://www.youtube.com/watch?v=dQw4w9WgXcQ\' : ExpandedURL:{https://www.youtube.com/watch?v=dQw4w9WgXcQ/diuwheiyfgbeioyrg/39486y7834....}, \'https://www.reddit.com/\' : ExpandedURL:{https://www.reddit.com/r/regex/...}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end