const regex = /^\{(((?<url>'\S+') : ExpandedURL:\{(?<exp_url>\S+)}(?:, |\}))+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\{(((?<url>\'\\S+\') : ExpandedURL:\\{(?<exp_url>\\S+)}(?:, |\\}))+)', 'gm')
const str = `{'https://www.google.com/search?q=red+cars' : ExpandedURL:{https://www.google.com/search?q=red+cars&sca_esv=3c36029106bf5d13&source=hp&ei=QTuIaI_t...}, 'https://www.youtube.com/watch?v=dQw4w9WgXcQ' : ExpandedURL:{https://www.youtube.com/watch?v=dQw4w9WgXcQ/diuwheiyfgbeioyrg/39486y7834....}, 'https://www.reddit.com/' : ExpandedURL:{https://www.reddit.com/r/regex/...}}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}