import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\{(((?<url>'\\S+') : ExpandedURL:\\{(?<exp_url>\\S+)\\}(?:, |\\}))+)";
final String string = "{'https://www.google.com/search?q=red+cars' : ExpandedURL:{https://www.google.com/search?q=red+cars&sca_esv=3c36029106bf5d13&source=hp&ei=QTuIaI_t...}, 'https://www.youtube.com/watch?v=dQw4w9WgXcQ' : ExpandedURL:{https://www.youtube.com/watch?v=dQw4w9WgXcQ/diuwheiyfgbeioyrg/39486y7834....}, 'https://www.reddit.com/' : ExpandedURL:{https://www.reddit.com/r/regex/...}}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}