#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?|([a-zA-Z0-9]+)\(([a-zA-Z\s]+)\)|\(([a-zA-Z\s]+)\)([a-zA-Z0-9]+))"
Local $sString = "(Weather) is good. // not need to mark this beacuase this word konown word" & @CRLF & _
"Weath(er) is good. // mark" & @CRLF & _
"Weath(er is good). // mark" & @CRLF & _
"Weather (is) (good)." & @CRLF & _
"My name is Rah(eel) // mark" & @CRLF & _
"Best pro(duct) // mark" & @CRLF & _
"(Weather is good) // not need to mark this beacuase this word konown word" & @CRLF & _
"we(ather)" & @CRLF & _
"(weath)er is good. // i want to mark this word" & @CRLF & _
"(weath)er // i want to mark this word" & @CRLF & _
"weather(is fine)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")