const regex = /(?|([a-zA-Z0-9]+)\(([a-zA-Z\s]+)\)|\(([a-zA-Z\s]+)\)([a-zA-Z0-9]+))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?|([a-zA-Z0-9]+)\\(([a-zA-Z\\s]+)\\)|\\(([a-zA-Z\\s]+)\\)([a-zA-Z0-9]+))', 'g')
const str = `(Weather) is good. // not need to mark this beacuase this word konown word
Weath(er) is good. // mark
Weath(er is good). // mark
Weather (is) (good).
My name is Rah(eel) // mark
Best pro(duct) // mark
(Weather is good) // not need to mark this beacuase this word konown word
we(ather)
(weath)er is good. // i want to mark this word
(weath)er // i want to mark this word
weather(is fine)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}