re = /(?|([a-zA-Z0-9]+)\(([a-zA-Z\s]+)\)|\(([a-zA-Z\s]+)\)([a-zA-Z0-9]+))/
str = '(Weather) is good. // not need to mark this beacuase this word konown word
Weath(er) is good. // mark
Weath(er is good). // mark
Weather (is) (good).
My name is Rah(eel) // mark
Best pro(duct) // mark
(Weather is good) // not need to mark this beacuase this word konown word
we(ather)
(weath)er is good. // i want to mark this word
(weath)er // i want to mark this word
weather(is fine)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end