import Foundation
let pattern = #"(?|([a-zA-Z0-9]+)\(([a-zA-Z\s]+)\)|\(([a-zA-Z\s]+)\)([a-zA-Z0-9]+))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
(Weather) is good. // not need to mark this beacuase this word konown word
Weath(er) is good. // mark
Weath(er is good). // mark
Weather (is) (good).
My name is Rah(eel) // mark
Best pro(duct) // mark
(Weather is good) // not need to mark this beacuase this word konown word
we(ather)
(weath)er is good. // i want to mark this word
(weath)er // i want to mark this word
weather(is fine)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)