import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?|([a-zA-Z0-9]+)\\(([a-zA-Z\\s]+)\\)|\\(([a-zA-Z\\s]+)\\)([a-zA-Z0-9]+))";
final String string = "(Weather) is good. // not need to mark this beacuase this word konown word\n"
+ "Weath(er) is good. // mark\n"
+ "Weath(er is good). // mark\n"
+ "Weather (is) (good).\n"
+ "My name is Rah(eel) // mark\n"
+ "Best pro(duct) // mark\n"
+ "(Weather is good) // not need to mark this beacuase this word konown word\n"
+ "we(ather)\n"
+ "(weath)er is good. // i want to mark this word\n"
+ "(weath)er // i want to mark this word\n"
+ "weather(is fine)\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}