#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?!foo|bar).)+@.*$"
Local $sString = "abcfooxyz@domain.com" & @CRLF & _
"barabc@domain.com" & @CRLF & _
"barabc@domainfoo.com" & @CRLF & _
"abcxyz@domainfoo.com" & @CRLF & _
"pqrabc@domainbar.com" & @CRLF & _
"pqrabc@domain.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")