$re = '/^((?!foo|bar).)+@.*$/m';
$str = 'abcfooxyz@domain.com
barabc@domain.com
barabc@domainfoo.com
abcxyz@domainfoo.com
pqrabc@domainbar.com
pqrabc@domain.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);