import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?!foo|bar).)+@.*$";
final String string = "abcfooxyz@domain.com\n"
+ "barabc@domain.com\n"
+ "barabc@domainfoo.com\n"
+ "abcxyz@domainfoo.com\n"
+ "pqrabc@domainbar.com\n"
+ "pqrabc@domain.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}