using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"""Id"":""(?<campid>.*?)"",""Status"":""(?<status>.*?)"",""Five9__Five9list__c"":""(?<five9list>.*?)""}]}";
        string input = @"{""searchRecords"":[{""attributes"":{""type"":""Campaign"",""url"":""/services/data/v43.0/sobjects/Campaign/701C0000000sVOVIA2""},""Id"":""701C0000000sVOVIA2"",""Status"":""Planned"",""Five9__Five9list__c"":""Toast_list_outbound""}]}";
        RegexOptions options = RegexOptions.Multiline;
        
        foreach (Match m in Regex.Matches(input, pattern, options))
        {
            Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
        }
    }
}