import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"Id\":\"(?<campid>.*?)\",\"Status\":\"(?<status>.*?)\",\"Five9__Five9list__c\":\"(?<five9list>.*?)\"\\}]\\}";
final String string = "{\"searchRecords\":[{\"attributes\":{\"type\":\"Campaign\",\"url\":\"/services/data/v43.0/sobjects/Campaign/701C0000000sVOVIA2\"},\"Id\":\"701C0000000sVOVIA2\",\"Status\":\"Planned\",\"Five9__Five9list__c\":\"Toast_list_outbound\"}]}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}