import re
regex = re.compile(r"\"Id\":\"(?<campid>.*?)\",\"Status\":\"(?<status>.*?)\",\"Five9__Five9list__c\":\"(?<five9list>.*?)\"}]}", flags=re.MULTILINE)
test_str = "{\"searchRecords\":[{\"attributes\":{\"type\":\"Campaign\",\"url\":\"/services/data/v43.0/sobjects/Campaign/701C0000000sVOVIA2\"},\"Id\":\"701C0000000sVOVIA2\",\"Status\":\"Planned\",\"Five9__Five9list__c\":\"Toast_list_outbound\"}]}"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")