// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"Id":"(?<campid>.*?)","Status":"(?<status>.*?)","Five9__Five9list__c":"(?<five9list>.*?)"}]}"#).unwrap();
let string = "{\"searchRecords\":[{\"attributes\":{\"type\":\"Campaign\",\"url\":\"/services/data/v43.0/sobjects/Campaign/701C0000000sVOVIA2\"},\"Id\":\"701C0000000sVOVIA2\",\"Status\":\"Planned\",\"Five9__Five9list__c\":\"Toast_list_outbound\"}]}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}