const regex = /^\d*\D.*(*SKIP)(*F)|456/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d*\\D.*(*SKIP)(*F)|456', 'gm')
const str = `4564567890`;
const subst = `999`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);