// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d*\D.*(*SKIP)(*F)|456").unwrap();
let string = "4564567890";
let substitution = "999";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}