use strict;
my $str = '4564567890';
my $regex = qr/^\d*\D.*(*SKIP)(*F)|456/mp;
my $subst = '999';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";