import Foundation
let pattern = #"^\d*\D.*(*SKIP)(*F)|456"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"4564567890"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"999"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)