#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\B"
Local $sString = "2.3.5...9" & @CRLF & _
"4..." & @CRLF & _
"..."
Local $sSubst = "0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)