use strict;
my $str = '2.3.5...9
4...
...';
my $regex = qr/\B/mp;
my $subst = '0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";