const regex = /\B/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\B', 'gm')
const str = `2.3.5...9
4...
...`;
const subst = `0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);