$re = '/\B/m';
$str = '2.3.5...9
4...
...';
$subst = "0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;